Incorrect username or password

 
08-07-2020 09:42
|
Season 75 · Week 1 · Day 2
|
Online: 3 337

Football

Football » English » Simulator Development Feedback

Away Kit not working

Badge image
It seems that the away kit is not working.
Views: 153 Posts: 12
 
Page 1
 
Reply
Last Message

Re: Away Kit not working

Badge image
Badge image
[POW]
President
Hi. The away kit is not used in all matches -- only when the two primary colors are too similar. So you should rarely see it.

Re: Away Kit not working

Badge image
powdersnow wrote:
Hi. The away kit is not used in all matches -- only when the two primary colors are too similar. So you should rarely see it.


I'm talking about specifically the cases that the colors are too similar but the kit does not work.

See the cases below for example:

https://www.managerzone.com/?p=match&sub=result&mid=1118506144&tid=267288

https://www.managerzone.com/?p=match&sub=result&mid=1133885810

Re: Away Kit not working

Badge image
I second this feedback. In fact this is an annoying little bug that has been around for ages. Looks like the secondary color -and not the primary one- has been made the deciding factor by mistake. As a result a lot of matches are awful to watch, so fixing this would be great.

Re: Away Kit not working

Badge image
smaakeloos wrote:
I second this feedback. In fact this is an annoying little bug that has been around for ages. Looks like the secondary color -and not the primary one- has been made the deciding factor by mistake. As a result a lot of matches are awful to watch, so fixing this would be great.


Yeah, it is very annoying indeed.

Re: Away Kit not working

Badge image
Badge image
[POW]
President
doug: Your home and away kit have the exact same colors, primary and secondary.

I am going to go out on a limb and say that might have something to do with it. 😑

Re: Away Kit not working

Badge image
@Powdersnow: Ok, let me rephrase my earlier statement. The use of the away kit in this great game is a real mess. Watching a lot of 3D games for years in almost all cases an away kit is desperately needed it isn't activated, and in almost all cases where it is activated it isn't needed. Hence the mess. Also scrolling down my recent away games I know for a fact that secondary colors are triggering changes where primary ones should do that. What you wrote earlier in this thread is how it should work, not how it is working.

To keep it simple first just my last two matches playing away against a team with the same primary color. I play in white (primary) and red (secondary).

1 Fail

https://www.managerzone.com/?p=match&sub=result&mid=1134744700&tid=122461

White against white. Making the game almost unwatchable. As far as I can see in such cases the away kit will only be used if the secondary colors are also almost identical. In any case, the vast majority of my games against teams playing in the same (primary) color are played without away kit.

2 Epic fail

https://www.managerzone.com/?p=match&sub=result&mid=1134744680&tid=122461

If this match up is not exemplary for why away kits are introduced in the first place, save people the trouble setting them up and remove them all together I should say.

3 Correct (as an interesting exception which can help you recognizing the bug)

https://www.managerzone.com/?p=match&sub=result&mid=1134426608&tid=122461

And here is one of those few exceptions that the away kit is used properly. All I know based on experience and the other cases, it has to be triggered by the secondary colors (too similar or taking more in account because of the bigger area in the home kit).

4 Fail (albeit debatable, also as an indication what the bug exactly is)

https://www.managerzone.com/?p=match&sub=result&mid=1134360975&tid=122461

Away kit where it is totally unneccesary. Home team in red, apparantly matching my secondary color (maybe some might say that his secondary color matches my primary one, same difference).

Btw, I have also played in an all blue kit for a long time, having the same experience.

Hope this helps.

Re: Away Kit not working

Badge image
powdersnow wrote:
doug: Your home and away kit have the exact same colors, primary and secondary.

I am going to go out on a limb and say that might have something to do with it. 😑


Ok, thanks. I have changed the colors of the second kit to see if works now.

Re: Away Kit not working

Badge image
Badge image
[POW]
President
@smaakeloos: Alright, I see your point.

I think that what might be the cause of the problem, is that your home primary and away primary are too similar. Yes, one is white and the other is yellow, but they are both bright. The game will first test your home kit primary with the away kit primary. If they are too similar it'll do the exact same check on the away kit instead. But if the away kit primary is also too similar to the home primary, it'll just cycle back to the home kit and use that as default.

So I'd like to ask you to please choose a dark away primary, rather than a bright one, and see if that fixes the problem.

Re: Away Kit not working

Badge image
Changed. Also I had already switched my secondary color of my home kit to white, curious to see if that can do the trick. Now waiting for some opponents playing in white I will do some testing what works and what doesn't. In any case thanks for the reply, much appreciated!

Re: Away Kit not working

Badge image
Badge image
[POW]
President
Realized now my answer was a bit stupid, what I meant to say was that the game compares your home kit with the opponents home kit, then your away kit with the opponents home kit, but it seems you understood me anyway. Anyway let me know if you still have problems.

Re: Away Kit not working

Badge image
Have this problem sometimes, when forms are really different

Re: Away Kit not working

Badge image
moonlight-1992 wrote:
Have this problem sometimes, when forms are really different


You could be onto something there.

Having a look just now at all my recent away games I stumbled upon the following examples.

Away kit not activated:
https://www.managerzone.com/?p=match&sub=result&mid=1153530283&tid=122461
https://www.managerzone.com/?p=match&sub=result&mid=1152944716&tid=122461

Away kit activated:
https://www.managerzone.com/?p=match&sub=result&mid=1152582618&tid=122461
https://www.managerzone.com/?p=match&sub=result&mid=1151506947&tid=122461
https://www.managerzone.com/?p=match&sub=result&mid=1151551159&tid=122461

Based on these matches my best guess would be that the bug is to be found in the type of shirt (the pattern). With some types the engine just doesn't seem to make the switch, regardless of primary or even secondary colors. Unfortunately it doesn't explain one of the earlier links I posted in this thread:

https://www.managerzone.com/?p=match&sub=result&mid=1134744680&tid=122461

Riddle me this.
 
Page 1